Camera Issues

Camera Issues

Postby lumasong » October 20th, 2016, 1:03 pm

Hi! I'm having trouble with the UI, and particularly the camera movement, of my Sims 3 game. The camera moves frustratingly slow, or doesn't respond to my input at all. It's getting frustrating enough that I don't want to play anymore, which is sad.

Things to know:
I have played my legacy for 3 1/2 generations without this issue.
I have all EPs and SPs.
I have a bunch of store stuff, but no CC.
I have two mods: Nraas Overwatch and Errortrap. Removing them doesn't help.
Lowering the graphic options doesn't help.
Moving out 4 sims and a dog helped until I reloaded the game, then the problem returned (house now has 3 sims and no pets).
My computer is 9 years old, but like I said, I didn't have problems early on in the legacy.
Moving neighborhoods doesn't help.
Restarting the computer and playing without anything else open doesn't help.
The problem does not appear in Build/Buy mode, only in Live mode paused or unpaused.
Cameraman mode is not affected.
EDIT: I created a new Sunset Valley and used a small empty lot with one sim. Camera works perfectly.

That's all I can think of. I've considered rebuilding the house on a fresh lot or even a smaller lot, but that would be a pain... I'd rather not unless I think it would work.
Thanks for looking, at least! I hope someone has better ideas than I do.
User avatar
lumasong
Lemur Queen
House of Llama
 
Posts: 136
Joined: July 25th, 2014, 7:14 am
Location: Texas, USA
Medals: 6
Story of the Month (1) Gold SimNaNoWriMo Award 2016 (1) Happy Birthday (1) Teresa's Troll (1) Drinks on the House (1) Four Leaves of Clover (1)

Re: Camera Issues

Postby Ani-Mei » October 20th, 2016, 3:53 pm

Are you clearing your caches after every play? Leaving them untouched in the Sims 3 folder does make things lag. It generates caches and records of script errors in the folder after every play through. Try clearing them out after every play see if that helps. I can run a lot with eight sims for at least three generations before the lag makes me angry enough to move them and my computer is seven years old so I guess in technological years it's like a 70 year old, slow-ish and creaky but still works.
User avatar
Ani-Mei
Temporary Spiderella
Staff Moderator
 
Posts: 2781
Joined: July 26th, 2007, 5:15 am
Location: Traveling the Timestream
Medals: 56
Golden Plumbob 2016 (1) Golden Plumbob 2017 (1) The Rosanna Award (1) Sims 2 Legacy (1) Sims 3 Legacy (1) Boolprop Wacky Challenge (1) Apocalypse Challenge (1) Who's Your Daddy? (1) Story of the Month (1)
Completed a Challenge! (1) Boolprop NTM 12 Participant (1) 2014 Housewarming Gift Xchange (1) 2016 Summer Screenshot (1) 2017 Egg Hunt (1) Gold SimNaNoWriMo Award 2016 (1) Silver SimNaNoWriMo Award 2017 (1) Gold SimNaNoWriMo Award 2018 (1) Halloween Candy (1)
Halloween Zombie (1) Thanksgiving Turkey (1) 2015 Holiday Events (1) 2015 Christmas Gift Exchange (1) 2016 Valentine Events (1) 2016 Easter Events (1) Halloween 2016 (1) 2016 Holiday Events (1) 2017 Valentine Events (1)
2017 Halloween Events (1) 2017 Halloween Events - Cat (1) 2017 Pumpkin Hunt (1) 2017 Pumpkin Hunt - Gold (1) 2017 Snowman Hunt (1) 2017 Snowman Hunt - Gold (1) 2017 Xmas Events (1) 2017 Xmas Events - Advent (1) 2017 Xmas Events-Secret Santa (1)
2018 Valentine Events (1) 2018 Halloween Events (1) 2018 Bat Hunt (1) 2018 Pick a Treat - Black Cat (1) 2015 Birthday Toast (1) 2015 Birthday Party Hat (1) 2015 Birthday Balloon (1) 12th Birthday Event (1) Palmer Says ... (1)
Scavenger Hunt (1) Pass the Parcel (1) Pin the Plumbob (1) Happy Birthday (1) Teresa's Troll (1) Great Migration of 2014 (1) Pride (1) A Field of Red Poppies (1) Treasure Chest (1)
Four Leaves of Clover (1) Canada (1)

Re: Camera Issues

Postby DSLady » October 20th, 2016, 4:26 pm

Ani-Mei wrote:Are you clearing your caches after every play?


This ^^ I never used to do this until recently, and I feel like it's half the reason a lot of my saves became unplayable. They're in the Sims3 Folder in 'My Documents', and ones you want are anything that says ScriptError_[PCName] and the ones that are .package and have cache in the name (sorry if you already know this!!)

Is ErrorTrap throwing you anything? I had a similar issue (it was also accompanied by the game freezing) because of stray pets becoming stuck and unroutable - so much of the game's usage went to trying to route the pets that everything else suffered.
On a similar line, have you tried [resetsim *]? It resets the whole town so you know if it's a problem with stuck sims. Though, for me, pausing meant the camera worked again...
And have you googled it!? I've had a truck load of running errors that I managed to find answers to by seeing if somebody's the same or similar issue, and then bodge-jobing their soloution :rotfl: I don't really know much to help you more, but I hope that you find the answer soon! :)
Image
The Gordon Legacy - Gen Nine :: Runaway Gordon - A Runaway Teen Challenge :: Evans EPIC Challenge - Gen Five :: From Shadows - An Officially Wacky Boolprop Challenge
ImageImage
User avatar
DSLady
More Bitter Than Coffee
House of Smustle
 
Posts: 459
Joined: March 9th, 2016, 9:41 am
Location: Face down on the carpet, sobbing
Medals: 24
Golden Plumbob 2016 (1) Baby Boom Challenge (1) Story of the Month (1) Completed a Challenge! (1) Boolprop NTM 11 Winner (1) Boolprop NTM 12 Participant (1) 2016 Summer Screenshot (1) Gold SimNaNoWriMo Award 2016 (1) Gold SimNaNoWriMo Award 2017 (1)
Gold SimNaNoWriMo Award 2018 (1) Halloween 2016 (1) 2017 Halloween Events (1) 2017 Halloween Events - Cat (1) 2017 Xmas Events - Advent (1) 2018 Bat Hunt (1) 2018 Bat Hunt - Gold (1) 2018 Pick a Treat - Cat (1) 2018 Pick a Treat - Black Cat (1)
Happy Birthday (1) Pride (1) Little Ball of Fur (1) Bolt of Lightning (1) Four Leaves of Clover (1) Ireland (1)
Steam ID: dslady13

Re: Camera Issues

Postby lumasong » October 20th, 2016, 4:46 pm

It's been awhile since I cleaned out my caches, so I will give t hat a try! And I didn't know which ones were safe to delete, I've just been guessing, so thank you, DSLady!

I haven't noticed anything particularly odd from Errortrap except it rerouted my bride just as she was married and her husband disappeared and didn't move in. But the problem was happening before that.

I'm not sure it's a sim - like you said, I would expect the camera to work while paused if it was, but I'll give reseting the town a try if deleting the caches doesn't work. Can't make it worse at this point.

I have googled it! I've googled a lot of problems since this is my first time playing Sims 3, but for this one I couldn't find a clear answer. A lot of problems were solved by the things I listed above, lowering settings, moving neighborhoods, etc. This one just has me stumped.

Will report in to say what deleting caches did!

EDIT: No/little improvement to my main file. Will try the new neighborhood next.
EDIT2: Same with the new neighborhood.
EDIT3: Same problem with building a new house and moving them in.
EDIT4: The problem is actually tied to one specific Sim! The default selected one of course. I'm going to try cleaning out her inventory and see if that helps.
EDIT5: Worked like a treat. I deleted as much bloat from her inventory as I could, stashed her thousands of fruit in a chest, deleted the high school diplomas she's collected, and moved the gravestones to the family inventory. Problem solved! Oddly enough it was LIvvielove (the sole commenter on my legacy) on another forum who provided the solution, so thanks again to Livvie! I love you so much.
User avatar
lumasong
Lemur Queen
House of Llama
 
Posts: 136
Joined: July 25th, 2014, 7:14 am
Location: Texas, USA
Medals: 6
Story of the Month (1) Gold SimNaNoWriMo Award 2016 (1) Happy Birthday (1) Teresa's Troll (1) Drinks on the House (1) Four Leaves of Clover (1)


Return to Sims 3 Help!

Who is online

Users browsing this forum: No registered users and 7 guests